{"columns":["Code","Name","Key exchange","Cipher","Hash","IANA status","DTLS","Reference"],"rows":[["0x0000","TLS_NULL_WITH_NULL_NULL","NULL","NULL","NULL","Not recommended","Yes","RFC5246"],["0x0001","TLS_RSA_WITH_NULL_MD5","RSA","NULL","MD5","Discouraged","Yes","RFC5246, RFC10015"],["0x0002","TLS_RSA_WITH_NULL_SHA","RSA","NULL","SHA","Discouraged","Yes","RFC5246, RFC10015"],["0x0003","TLS_RSA_EXPORT_WITH_RC4_40_MD5","RSA EXPORT","RC4 40","MD5","Discouraged","No","RFC4346, RFC6347, RFC10015"],["0x0004","TLS_RSA_WITH_RC4_128_MD5","RSA","RC4 128","MD5","Discouraged","No","RFC5246, RFC6347, RFC10015"],["0x0005","TLS_RSA_WITH_RC4_128_SHA","RSA","RC4 128","SHA","Discouraged","No","RFC5246, RFC6347, RFC10015"],["0x0006","TLS_RSA_EXPORT_WITH_RC2_CBC_40_MD5","RSA EXPORT","RC2 CBC 40","MD5","Discouraged","Yes","RFC4346, RFC10015"],["0x0007","TLS_RSA_WITH_IDEA_CBC_SHA","RSA","IDEA CBC","SHA","Discouraged","Yes","RFC8996, RFC10015"],["0x0008","TLS_RSA_EXPORT_WITH_DES40_CBC_SHA","RSA EXPORT","DES40 CBC","SHA","Discouraged","Yes","RFC4346, RFC10015"],["0x0009","TLS_RSA_WITH_DES_CBC_SHA","RSA","DES CBC","SHA","Discouraged","Yes","RFC8996, RFC10015"],["0x000A","TLS_RSA_WITH_3DES_EDE_CBC_SHA","RSA","3DES EDE CBC","SHA","Discouraged","Yes","RFC5246, RFC10015"],["0x000B","TLS_DH_DSS_EXPORT_WITH_DES40_CBC_SHA","DH DSS EXPORT","DES40 CBC","SHA","Discouraged","Yes","RFC4346, RFC10015"],["0x000C","TLS_DH_DSS_WITH_DES_CBC_SHA","DH DSS","DES CBC","SHA","Discouraged","Yes","RFC8996, RFC10015"],["0x000D","TLS_DH_DSS_WITH_3DES_EDE_CBC_SHA","DH DSS","3DES EDE CBC","SHA","Discouraged","Yes","RFC5246, RFC10015"],["0x000E","TLS_DH_RSA_EXPORT_WITH_DES40_CBC_SHA","DH RSA EXPORT","DES40 CBC","SHA","Discouraged","Yes","RFC4346, RFC10015"],["0x000F","TLS_DH_RSA_WITH_DES_CBC_SHA","DH RSA","DES CBC","SHA","Discouraged","Yes","RFC8996, RFC10015"],["0x0010","TLS_DH_RSA_WITH_3DES_EDE_CBC_SHA","DH RSA","3DES EDE CBC","SHA","Discouraged","Yes","RFC5246, RFC10015"],["0x0011","TLS_DHE_DSS_EXPORT_WITH_DES40_CBC_SHA","DHE DSS EXPORT","DES40 CBC","SHA","Discouraged","Yes","RFC4346, RFC10015"],["0x0012","TLS_DHE_DSS_WITH_DES_CBC_SHA","DHE DSS","DES CBC","SHA","Discouraged","Yes","RFC8996, RFC10015"],["0x0013","TLS_DHE_DSS_WITH_3DES_EDE_CBC_SHA","DHE DSS","3DES EDE CBC","SHA","Discouraged","Yes","RFC5246, RFC10015"],["0x0014","TLS_DHE_RSA_EXPORT_WITH_DES40_CBC_SHA","DHE RSA EXPORT","DES40 CBC","SHA","Discouraged","Yes","RFC4346, RFC10015"],["0x0015","TLS_DHE_RSA_WITH_DES_CBC_SHA","DHE RSA","DES CBC","SHA","Discouraged","Yes","RFC8996, RFC10015"],["0x0016","TLS_DHE_RSA_WITH_3DES_EDE_CBC_SHA","DHE RSA","3DES EDE CBC","SHA","Discouraged","Yes","RFC5246, RFC10015"],["0x0017","TLS_DH_anon_EXPORT_WITH_RC4_40_MD5","DH anon EXPORT","RC4 40","MD5","Discouraged","No","RFC4346, RFC6347, RFC10015"],["0x0018","TLS_DH_anon_WITH_RC4_128_MD5","DH anon","RC4 128","MD5","Discouraged","No","RFC5246, RFC6347, RFC10015"],["0x0019","TLS_DH_anon_EXPORT_WITH_DES40_CBC_SHA","DH anon EXPORT","DES40 CBC","SHA","Discouraged","Yes","RFC4346, RFC10015"],["0x001A","TLS_DH_anon_WITH_DES_CBC_SHA","DH anon","DES CBC","SHA","Discouraged","Yes","RFC8996, RFC10015"],["0x001B","TLS_DH_anon_WITH_3DES_EDE_CBC_SHA","DH anon","3DES EDE CBC","SHA","Discouraged","Yes","RFC5246, RFC10015"],["0x001E","TLS_KRB5_WITH_DES_CBC_SHA","KRB5","DES CBC","SHA","Discouraged","Yes","RFC2712, RFC9847"],["0x001F","TLS_KRB5_WITH_3DES_EDE_CBC_SHA","KRB5","3DES EDE CBC","SHA","Not recommended","Yes","RFC2712"],["0x0020","TLS_KRB5_WITH_RC4_128_SHA","KRB5","RC4 128","SHA","Discouraged","No","RFC2712, RFC6347, RFC9847"],["0x0021","TLS_KRB5_WITH_IDEA_CBC_SHA","KRB5","IDEA CBC","SHA","Discouraged","Yes","RFC2712, RFC9847"],["0x0022","TLS_KRB5_WITH_DES_CBC_MD5","KRB5","DES CBC","MD5","Discouraged","Yes","RFC2712, RFC9847"],["0x0023","TLS_KRB5_WITH_3DES_EDE_CBC_MD5","KRB5","3DES EDE CBC","MD5","Not recommended","Yes","RFC2712"],["0x0024","TLS_KRB5_WITH_RC4_128_MD5","KRB5","RC4 128","MD5","Discouraged","No","RFC2712, RFC6347, RFC9847"],["0x0025","TLS_KRB5_WITH_IDEA_CBC_MD5","KRB5","IDEA CBC","MD5","Discouraged","Yes","RFC2712, RFC9847"],["0x0026","TLS_KRB5_EXPORT_WITH_DES_CBC_40_SHA","KRB5 EXPORT","DES CBC 40","SHA","Discouraged","Yes","RFC2712, RFC9847"],["0x0027","TLS_KRB5_EXPORT_WITH_RC2_CBC_40_SHA","KRB5 EXPORT","RC2 CBC 40","SHA","Discouraged","Yes","RFC2712, RFC9847"],["0x0028","TLS_KRB5_EXPORT_WITH_RC4_40_SHA","KRB5 EXPORT","RC4 40","SHA","Discouraged","No","RFC2712, RFC6347, RFC9847"],["0x0029","TLS_KRB5_EXPORT_WITH_DES_CBC_40_MD5","KRB5 EXPORT","DES CBC 40","MD5","Discouraged","Yes","RFC2712, RFC9847"],["0x002A","TLS_KRB5_EXPORT_WITH_RC2_CBC_40_MD5","KRB5 EXPORT","RC2 CBC 40","MD5","Discouraged","Yes","RFC2712, RFC9847"],["0x002B","TLS_KRB5_EXPORT_WITH_RC4_40_MD5","KRB5 EXPORT","RC4 40","MD5","Discouraged","No","RFC2712, RFC6347, RFC9847"],["0x002C","TLS_PSK_WITH_NULL_SHA","PSK","NULL","SHA","Discouraged","Yes","RFC4785, RFC9847"],["0x002D","TLS_DHE_PSK_WITH_NULL_SHA","DHE PSK","NULL","SHA","Discouraged","Yes","RFC4785, RFC10015"],["0x002E","TLS_RSA_PSK_WITH_NULL_SHA","RSA PSK","NULL","SHA","Discouraged","Yes","RFC4785, RFC10015"],["0x002F","TLS_RSA_WITH_AES_128_CBC_SHA","RSA","AES 128 CBC","SHA","Discouraged","Yes","RFC5246, RFC10015"],["0x0030","TLS_DH_DSS_WITH_AES_128_CBC_SHA","DH DSS","AES 128 CBC","SHA","Discouraged","Yes","RFC5246, RFC10015"],["0x0031","TLS_DH_RSA_WITH_AES_128_CBC_SHA","DH RSA","AES 128 CBC","SHA","Discouraged","Yes","RFC5246, RFC10015"],["0x0032","TLS_DHE_DSS_WITH_AES_128_CBC_SHA","DHE DSS","AES 128 CBC","SHA","Discouraged","Yes","RFC5246, RFC10015"],["0x0033","TLS_DHE_RSA_WITH_AES_128_CBC_SHA","DHE RSA","AES 128 CBC","SHA","Discouraged","Yes","RFC5246, RFC10015"],["0x0034","TLS_DH_anon_WITH_AES_128_CBC_SHA","DH anon","AES 128 CBC","SHA","Discouraged","Yes","RFC5246, RFC10015"],["0x0035","TLS_RSA_WITH_AES_256_CBC_SHA","RSA","AES 256 CBC","SHA","Discouraged","Yes","RFC5246, RFC10015"],["0x0036","TLS_DH_DSS_WITH_AES_256_CBC_SHA","DH DSS","AES 256 CBC","SHA","Discouraged","Yes","RFC5246, RFC10015"],["0x0037","TLS_DH_RSA_WITH_AES_256_CBC_SHA","DH RSA","AES 256 CBC","SHA","Discouraged","Yes","RFC5246, RFC10015"],["0x0038","TLS_DHE_DSS_WITH_AES_256_CBC_SHA","DHE DSS","AES 256 CBC","SHA","Discouraged","Yes","RFC5246, RFC10015"],["0x0039","TLS_DHE_RSA_WITH_AES_256_CBC_SHA","DHE RSA","AES 256 CBC","SHA","Discouraged","Yes","RFC5246, RFC10015"],["0x003A","TLS_DH_anon_WITH_AES_256_CBC_SHA","DH anon","AES 256 CBC","SHA","Discouraged","Yes","RFC5246, RFC10015"],["0x003B","TLS_RSA_WITH_NULL_SHA256","RSA","NULL","SHA256","Discouraged","Yes","RFC5246, RFC10015"],["0x003C","TLS_RSA_WITH_AES_128_CBC_SHA256","RSA","AES 128 CBC","SHA256","Discouraged","Yes","RFC5246, RFC10015"],["0x003D","TLS_RSA_WITH_AES_256_CBC_SHA256","RSA","AES 256 CBC","SHA256","Discouraged","Yes","RFC5246, RFC10015"],["0x003E","TLS_DH_DSS_WITH_AES_128_CBC_SHA256","DH DSS","AES 128 CBC","SHA256","Discouraged","Yes","RFC5246, RFC10015"],["0x003F","TLS_DH_RSA_WITH_AES_128_CBC_SHA256","DH RSA","AES 128 CBC","SHA256","Discouraged","Yes","RFC5246, RFC10015"],["0x0040","TLS_DHE_DSS_WITH_AES_128_CBC_SHA256","DHE DSS","AES 128 CBC","SHA256","Discouraged","Yes","RFC5246, RFC10015"],["0x0041","TLS_RSA_WITH_CAMELLIA_128_CBC_SHA","RSA","CAMELLIA 128 CBC","SHA","Discouraged","Yes","RFC5932, RFC10015"],["0x0042","TLS_DH_DSS_WITH_CAMELLIA_128_CBC_SHA","DH DSS","CAMELLIA 128 CBC","SHA","Discouraged","Yes","RFC5932, RFC10015"],["0x0043","TLS_DH_RSA_WITH_CAMELLIA_128_CBC_SHA","DH RSA","CAMELLIA 128 CBC","SHA","Discouraged","Yes","RFC5932, RFC10015"],["0x0044","TLS_DHE_DSS_WITH_CAMELLIA_128_CBC_SHA","DHE DSS","CAMELLIA 128 CBC","SHA","Discouraged","Yes","RFC5932, RFC10015"],["0x0045","TLS_DHE_RSA_WITH_CAMELLIA_128_CBC_SHA","DHE RSA","CAMELLIA 128 CBC","SHA","Discouraged","Yes","RFC5932, RFC10015"],["0x0046","TLS_DH_anon_WITH_CAMELLIA_128_CBC_SHA","DH anon","CAMELLIA 128 CBC","SHA","Discouraged","Yes","RFC5932, RFC10015"],["0x0067","TLS_DHE_RSA_WITH_AES_128_CBC_SHA256","DHE RSA","AES 128 CBC","SHA256","Discouraged","Yes","RFC5246, RFC10015"],["0x0068","TLS_DH_DSS_WITH_AES_256_CBC_SHA256","DH DSS","AES 256 CBC","SHA256","Discouraged","Yes","RFC5246, RFC10015"],["0x0069","TLS_DH_RSA_WITH_AES_256_CBC_SHA256","DH RSA","AES 256 CBC","SHA256","Discouraged","Yes","RFC5246, RFC10015"],["0x006A","TLS_DHE_DSS_WITH_AES_256_CBC_SHA256","DHE DSS","AES 256 CBC","SHA256","Discouraged","Yes","RFC5246, RFC10015"],["0x006B","TLS_DHE_RSA_WITH_AES_256_CBC_SHA256","DHE RSA","AES 256 CBC","SHA256","Discouraged","Yes","RFC5246, RFC10015"],["0x006C","TLS_DH_anon_WITH_AES_128_CBC_SHA256","DH anon","AES 128 CBC","SHA256","Discouraged","Yes","RFC5246, RFC10015"],["0x006D","TLS_DH_anon_WITH_AES_256_CBC_SHA256","DH anon","AES 256 CBC","SHA256","Discouraged","Yes","RFC5246, RFC10015"],["0x006E","TLS_ASCONAEAD128_ASCONHASH256","Any (TLS 1.3)","ASCONAEAD128 ASCONHASH256","","Not recommended","Yes","https://doi.org/10.6028/NIST.SP.800-232"],["0x006F","TLS_ASCONAEAD128_SHA256","Any (TLS 1.3)","ASCONAEAD128","SHA256","Not recommended","Yes","https://doi.org/10.6028/NIST.SP.800-232, RFC9846"],["0x0070","TLS_AES_128_GCM_ASCONHASH256","Any (TLS 1.3)","AES 128 GCM ASCONHASH256","","Not recommended","Yes","https://doi.org/10.6028/NIST.SP.800-232, RFC9846"],["0x0071","TLS_AES_128_CCM_ASCONHASH256","Any (TLS 1.3)","AES 128 CCM ASCONHASH256","","Not recommended","Yes","https://doi.org/10.6028/NIST.SP.800-232, RFC9846"],["0x0084","TLS_RSA_WITH_CAMELLIA_256_CBC_SHA","RSA","CAMELLIA 256 CBC","SHA","Discouraged","Yes","RFC5932, RFC10015"],["0x0085","TLS_DH_DSS_WITH_CAMELLIA_256_CBC_SHA","DH DSS","CAMELLIA 256 CBC","SHA","Discouraged","Yes","RFC5932, RFC10015"],["0x0086","TLS_DH_RSA_WITH_CAMELLIA_256_CBC_SHA","DH RSA","CAMELLIA 256 CBC","SHA","Discouraged","Yes","RFC5932, RFC10015"],["0x0087","TLS_DHE_DSS_WITH_CAMELLIA_256_CBC_SHA","DHE DSS","CAMELLIA 256 CBC","SHA","Discouraged","Yes","RFC5932, RFC10015"],["0x0088","TLS_DHE_RSA_WITH_CAMELLIA_256_CBC_SHA","DHE RSA","CAMELLIA 256 CBC","SHA","Discouraged","Yes","RFC5932, RFC10015"],["0x0089","TLS_DH_anon_WITH_CAMELLIA_256_CBC_SHA","DH anon","CAMELLIA 256 CBC","SHA","Discouraged","Yes","RFC5932, RFC10015"],["0x008A","TLS_PSK_WITH_RC4_128_SHA","PSK","RC4 128","SHA","Discouraged","No","RFC4279, RFC6347, RFC9847"],["0x008B","TLS_PSK_WITH_3DES_EDE_CBC_SHA","PSK","3DES EDE CBC","SHA","Not recommended","Yes","RFC4279"],["0x008C","TLS_PSK_WITH_AES_128_CBC_SHA","PSK","AES 128 CBC","SHA","Not recommended","Yes","RFC4279"],["0x008D","TLS_PSK_WITH_AES_256_CBC_SHA","PSK","AES 256 CBC","SHA","Not recommended","Yes","RFC4279"],["0x008E","TLS_DHE_PSK_WITH_RC4_128_SHA","DHE PSK","RC4 128","SHA","Discouraged","No","RFC4279, RFC6347, RFC10015"],["0x008F","TLS_DHE_PSK_WITH_3DES_EDE_CBC_SHA","DHE PSK","3DES EDE CBC","SHA","Discouraged","Yes","RFC4279, RFC10015"],["0x0090","TLS_DHE_PSK_WITH_AES_128_CBC_SHA","DHE PSK","AES 128 CBC","SHA","Discouraged","Yes","RFC4279, RFC10015"],["0x0091","TLS_DHE_PSK_WITH_AES_256_CBC_SHA","DHE PSK","AES 256 CBC","SHA","Discouraged","Yes","RFC4279, RFC10015"],["0x0092","TLS_RSA_PSK_WITH_RC4_128_SHA","RSA PSK","RC4 128","SHA","Discouraged","No","RFC4279, RFC6347, RFC10015"],["0x0093","TLS_RSA_PSK_WITH_3DES_EDE_CBC_SHA","RSA PSK","3DES EDE CBC","SHA","Discouraged","Yes","RFC4279, RFC10015"],["0x0094","TLS_RSA_PSK_WITH_AES_128_CBC_SHA","RSA PSK","AES 128 CBC","SHA","Discouraged","Yes","RFC4279, RFC10015"],["0x0095","TLS_RSA_PSK_WITH_AES_256_CBC_SHA","RSA PSK","AES 256 CBC","SHA","Discouraged","Yes","RFC4279, RFC10015"],["0x0096","TLS_RSA_WITH_SEED_CBC_SHA","RSA","SEED CBC","SHA","Discouraged","Yes","RFC4162, RFC10015"],["0x0097","TLS_DH_DSS_WITH_SEED_CBC_SHA","DH DSS","SEED CBC","SHA","Discouraged","Yes","RFC4162, RFC10015"],["0x0098","TLS_DH_RSA_WITH_SEED_CBC_SHA","DH RSA","SEED CBC","SHA","Discouraged","Yes","RFC4162, RFC10015"],["0x0099","TLS_DHE_DSS_WITH_SEED_CBC_SHA","DHE DSS","SEED CBC","SHA","Discouraged","Yes","RFC4162, RFC10015"],["0x009A","TLS_DHE_RSA_WITH_SEED_CBC_SHA","DHE RSA","SEED CBC","SHA","Discouraged","Yes","RFC4162, RFC10015"],["0x009B","TLS_DH_anon_WITH_SEED_CBC_SHA","DH anon","SEED CBC","SHA","Discouraged","Yes","RFC4162, RFC10015"],["0x009C","TLS_RSA_WITH_AES_128_GCM_SHA256","RSA","AES 128 GCM","SHA256","Discouraged","Yes","RFC5288, RFC10015"],["0x009D","TLS_RSA_WITH_AES_256_GCM_SHA384","RSA","AES 256 GCM","SHA384","Discouraged","Yes","RFC5288, RFC10015"],["0x009E","TLS_DHE_RSA_WITH_AES_128_GCM_SHA256","DHE RSA","AES 128 GCM","SHA256","Discouraged","Yes","RFC5288, RFC10015"],["0x009F","TLS_DHE_RSA_WITH_AES_256_GCM_SHA384","DHE RSA","AES 256 GCM","SHA384","Discouraged","Yes","RFC5288, RFC10015"],["0x00A0","TLS_DH_RSA_WITH_AES_128_GCM_SHA256","DH RSA","AES 128 GCM","SHA256","Discouraged","Yes","RFC5288, RFC10015"],["0x00A1","TLS_DH_RSA_WITH_AES_256_GCM_SHA384","DH RSA","AES 256 GCM","SHA384","Discouraged","Yes","RFC5288, RFC10015"],["0x00A2","TLS_DHE_DSS_WITH_AES_128_GCM_SHA256","DHE DSS","AES 128 GCM","SHA256","Discouraged","Yes","RFC5288, RFC10015"],["0x00A3","TLS_DHE_DSS_WITH_AES_256_GCM_SHA384","DHE DSS","AES 256 GCM","SHA384","Discouraged","Yes","RFC5288, RFC10015"],["0x00A4","TLS_DH_DSS_WITH_AES_128_GCM_SHA256","DH DSS","AES 128 GCM","SHA256","Discouraged","Yes","RFC5288, RFC10015"],["0x00A5","TLS_DH_DSS_WITH_AES_256_GCM_SHA384","DH DSS","AES 256 GCM","SHA384","Discouraged","Yes","RFC5288, RFC10015"],["0x00A6","TLS_DH_anon_WITH_AES_128_GCM_SHA256","DH anon","AES 128 GCM","SHA256","Discouraged","Yes","RFC5288, RFC10015"],["0x00A7","TLS_DH_anon_WITH_AES_256_GCM_SHA384","DH anon","AES 256 GCM","SHA384","Discouraged","Yes","RFC5288, RFC10015"],["0x00A8","TLS_PSK_WITH_AES_128_GCM_SHA256","PSK","AES 128 GCM","SHA256","Not recommended","Yes","RFC5487"],["0x00A9","TLS_PSK_WITH_AES_256_GCM_SHA384","PSK","AES 256 GCM","SHA384","Not recommended","Yes","RFC5487"],["0x00AA","TLS_DHE_PSK_WITH_AES_128_GCM_SHA256","DHE PSK","AES 128 GCM","SHA256","Discouraged","Yes","RFC5487, RFC10015"],["0x00AB","TLS_DHE_PSK_WITH_AES_256_GCM_SHA384","DHE PSK","AES 256 GCM","SHA384","Discouraged","Yes","RFC5487, RFC10015"],["0x00AC","TLS_RSA_PSK_WITH_AES_128_GCM_SHA256","RSA PSK","AES 128 GCM","SHA256","Discouraged","Yes","RFC5487, RFC10015"],["0x00AD","TLS_RSA_PSK_WITH_AES_256_GCM_SHA384","RSA PSK","AES 256 GCM","SHA384","Discouraged","Yes","RFC5487, RFC10015"],["0x00AE","TLS_PSK_WITH_AES_128_CBC_SHA256","PSK","AES 128 CBC","SHA256","Not recommended","Yes","RFC5487"],["0x00AF","TLS_PSK_WITH_AES_256_CBC_SHA384","PSK","AES 256 CBC","SHA384","Not recommended","Yes","RFC5487"],["0x00B0","TLS_PSK_WITH_NULL_SHA256","PSK","NULL","SHA256","Discouraged","Yes","RFC5487, RFC9847"],["0x00B1","TLS_PSK_WITH_NULL_SHA384","PSK","NULL","SHA384","Discouraged","Yes","RFC5487, RFC9847"],["0x00B2","TLS_DHE_PSK_WITH_AES_128_CBC_SHA256","DHE PSK","AES 128 CBC","SHA256","Discouraged","Yes","RFC5487, RFC10015"],["0x00B3","TLS_DHE_PSK_WITH_AES_256_CBC_SHA384","DHE PSK","AES 256 CBC","SHA384","Discouraged","Yes","RFC5487, RFC10015"],["0x00B4","TLS_DHE_PSK_WITH_NULL_SHA256","DHE PSK","NULL","SHA256","Discouraged","Yes","RFC5487, RFC10015"],["0x00B5","TLS_DHE_PSK_WITH_NULL_SHA384","DHE PSK","NULL","SHA384","Discouraged","Yes","RFC5487, RFC10015"],["0x00B6","TLS_RSA_PSK_WITH_AES_128_CBC_SHA256","RSA PSK","AES 128 CBC","SHA256","Discouraged","Yes","RFC5487, RFC10015"],["0x00B7","TLS_RSA_PSK_WITH_AES_256_CBC_SHA384","RSA PSK","AES 256 CBC","SHA384","Discouraged","Yes","RFC5487, RFC10015"],["0x00B8","TLS_RSA_PSK_WITH_NULL_SHA256","RSA PSK","NULL","SHA256","Discouraged","Yes","RFC5487, RFC10015"],["0x00B9","TLS_RSA_PSK_WITH_NULL_SHA384","RSA PSK","NULL","SHA384","Discouraged","Yes","RFC5487, RFC10015"],["0x00BA","TLS_RSA_WITH_CAMELLIA_128_CBC_SHA256","RSA","CAMELLIA 128 CBC","SHA256","Discouraged","Yes","RFC5932, RFC10015"],["0x00BB","TLS_DH_DSS_WITH_CAMELLIA_128_CBC_SHA256","DH DSS","CAMELLIA 128 CBC","SHA256","Discouraged","Yes","RFC5932, RFC10015"],["0x00BC","TLS_DH_RSA_WITH_CAMELLIA_128_CBC_SHA256","DH RSA","CAMELLIA 128 CBC","SHA256","Discouraged","Yes","RFC5932, RFC10015"],["0x00BD","TLS_DHE_DSS_WITH_CAMELLIA_128_CBC_SHA256","DHE DSS","CAMELLIA 128 CBC","SHA256","Discouraged","Yes","RFC5932, RFC10015"],["0x00BE","TLS_DHE_RSA_WITH_CAMELLIA_128_CBC_SHA256","DHE RSA","CAMELLIA 128 CBC","SHA256","Discouraged","Yes","RFC5932, RFC10015"],["0x00BF","TLS_DH_anon_WITH_CAMELLIA_128_CBC_SHA256","DH anon","CAMELLIA 128 CBC","SHA256","Discouraged","Yes","RFC5932, RFC10015"],["0x00C0","TLS_RSA_WITH_CAMELLIA_256_CBC_SHA256","RSA","CAMELLIA 256 CBC","SHA256","Discouraged","Yes","RFC5932, RFC10015"],["0x00C1","TLS_DH_DSS_WITH_CAMELLIA_256_CBC_SHA256","DH DSS","CAMELLIA 256 CBC","SHA256","Discouraged","Yes","RFC5932, RFC10015"],["0x00C2","TLS_DH_RSA_WITH_CAMELLIA_256_CBC_SHA256","DH RSA","CAMELLIA 256 CBC","SHA256","Discouraged","Yes","RFC5932, RFC10015"],["0x00C3","TLS_DHE_DSS_WITH_CAMELLIA_256_CBC_SHA256","DHE DSS","CAMELLIA 256 CBC","SHA256","Discouraged","Yes","RFC5932, RFC10015"],["0x00C4","TLS_DHE_RSA_WITH_CAMELLIA_256_CBC_SHA256","DHE RSA","CAMELLIA 256 CBC","SHA256","Discouraged","Yes","RFC5932, RFC10015"],["0x00C5","TLS_DH_anon_WITH_CAMELLIA_256_CBC_SHA256","DH anon","CAMELLIA 256 CBC","SHA256","Discouraged","Yes","RFC5932, RFC10015"],["0x00C6","TLS_SM4_GCM_SM3","Any (TLS 1.3)","SM4 GCM","SM3","Not recommended","No","RFC8998"],["0x00C7","TLS_SM4_CCM_SM3","Any (TLS 1.3)","SM4 CCM","SM3","Not recommended","No","RFC8998"],["0x1301","TLS_AES_128_GCM_SHA256","Any (TLS 1.3)","AES 128 GCM","SHA256","Recommended","Yes","RFC9846"],["0x1302","TLS_AES_256_GCM_SHA384","Any (TLS 1.3)","AES 256 GCM","SHA384","Recommended","Yes","RFC9846"],["0x1303","TLS_CHACHA20_POLY1305_SHA256","Any (TLS 1.3)","CHACHA20 POLY1305","SHA256","Recommended","Yes","RFC9846"],["0x1304","TLS_AES_128_CCM_SHA256","Any (TLS 1.3)","AES 128 CCM","SHA256","Recommended","Yes","RFC9846"],["0x1305","TLS_AES_128_CCM_8_SHA256","Any (TLS 1.3)","AES 128 CCM 8","SHA256","Not recommended","Yes","RFC9846, IESG Action 2018-08-16"],["0x1306","TLS_AEGIS_256_SHA512","Any (TLS 1.3)","AEGIS 256","SHA512","Not recommended","Yes","draft-irtf-cfrg-aegis-aead-08"],["0x1307","TLS_AEGIS_128L_SHA256","Any (TLS 1.3)","AEGIS 128L","SHA256","Not recommended","Yes","draft-irtf-cfrg-aegis-aead-08"],["0xC001","TLS_ECDH_ECDSA_WITH_NULL_SHA","ECDH ECDSA","NULL","SHA","Discouraged","Yes","RFC8422, RFC10015"],["0xC002","TLS_ECDH_ECDSA_WITH_RC4_128_SHA","ECDH ECDSA","RC4 128","SHA","Discouraged","No","RFC8422, RFC6347, RFC10015"],["0xC003","TLS_ECDH_ECDSA_WITH_3DES_EDE_CBC_SHA","ECDH ECDSA","3DES EDE CBC","SHA","Discouraged","Yes","RFC8422, RFC10015"],["0xC004","TLS_ECDH_ECDSA_WITH_AES_128_CBC_SHA","ECDH ECDSA","AES 128 CBC","SHA","Discouraged","Yes","RFC8422, RFC10015"],["0xC005","TLS_ECDH_ECDSA_WITH_AES_256_CBC_SHA","ECDH ECDSA","AES 256 CBC","SHA","Discouraged","Yes","RFC8422, RFC10015"],["0xC006","TLS_ECDHE_ECDSA_WITH_NULL_SHA","ECDHE ECDSA","NULL","SHA","Discouraged","Yes","RFC8422, RFC9847"],["0xC007","TLS_ECDHE_ECDSA_WITH_RC4_128_SHA","ECDHE ECDSA","RC4 128","SHA","Discouraged","No","RFC8422, RFC6347, RFC9847"],["0xC008","TLS_ECDHE_ECDSA_WITH_3DES_EDE_CBC_SHA","ECDHE ECDSA","3DES EDE CBC","SHA","Not recommended","Yes","RFC8422"],["0xC009","TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA","ECDHE ECDSA","AES 128 CBC","SHA","Not recommended","Yes","RFC8422"],["0xC00A","TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA","ECDHE ECDSA","AES 256 CBC","SHA","Not recommended","Yes","RFC8422"],["0xC00B","TLS_ECDH_RSA_WITH_NULL_SHA","ECDH RSA","NULL","SHA","Discouraged","Yes","RFC8422, RFC10015"],["0xC00C","TLS_ECDH_RSA_WITH_RC4_128_SHA","ECDH RSA","RC4 128","SHA","Discouraged","No","RFC8422, RFC6347, RFC10015"],["0xC00D","TLS_ECDH_RSA_WITH_3DES_EDE_CBC_SHA","ECDH RSA","3DES EDE CBC","SHA","Discouraged","Yes","RFC8422, RFC10015"],["0xC00E","TLS_ECDH_RSA_WITH_AES_128_CBC_SHA","ECDH RSA","AES 128 CBC","SHA","Discouraged","Yes","RFC8422, RFC10015"],["0xC00F","TLS_ECDH_RSA_WITH_AES_256_CBC_SHA","ECDH RSA","AES 256 CBC","SHA","Discouraged","Yes","RFC8422, RFC10015"],["0xC010","TLS_ECDHE_RSA_WITH_NULL_SHA","ECDHE RSA","NULL","SHA","Discouraged","Yes","RFC8422, RFC9847"],["0xC011","TLS_ECDHE_RSA_WITH_RC4_128_SHA","ECDHE RSA","RC4 128","SHA","Discouraged","No","RFC8422, RFC6347, RFC9847"],["0xC012","TLS_ECDHE_RSA_WITH_3DES_EDE_CBC_SHA","ECDHE RSA","3DES EDE CBC","SHA","Not recommended","Yes","RFC8422"],["0xC013","TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA","ECDHE RSA","AES 128 CBC","SHA","Not recommended","Yes","RFC8422"],["0xC014","TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA","ECDHE RSA","AES 256 CBC","SHA","Not recommended","Yes","RFC8422"],["0xC015","TLS_ECDH_anon_WITH_NULL_SHA","ECDH anon","NULL","SHA","Discouraged","Yes","RFC8422, RFC10015"],["0xC016","TLS_ECDH_anon_WITH_RC4_128_SHA","ECDH anon","RC4 128","SHA","Discouraged","No","RFC8422, RFC6347, RFC10015"],["0xC017","TLS_ECDH_anon_WITH_3DES_EDE_CBC_SHA","ECDH anon","3DES EDE CBC","SHA","Discouraged","Yes","RFC8422, RFC10015"],["0xC018","TLS_ECDH_anon_WITH_AES_128_CBC_SHA","ECDH anon","AES 128 CBC","SHA","Discouraged","Yes","RFC8422, RFC10015"],["0xC019","TLS_ECDH_anon_WITH_AES_256_CBC_SHA","ECDH anon","AES 256 CBC","SHA","Discouraged","Yes","RFC8422, RFC10015"],["0xC01A","TLS_SRP_SHA_WITH_3DES_EDE_CBC_SHA","SRP SHA","3DES EDE CBC","SHA","Not recommended","Yes","RFC5054"],["0xC01B","TLS_SRP_SHA_RSA_WITH_3DES_EDE_CBC_SHA","SRP SHA RSA","3DES EDE CBC","SHA","Not recommended","Yes","RFC5054"],["0xC01C","TLS_SRP_SHA_DSS_WITH_3DES_EDE_CBC_SHA","SRP SHA DSS","3DES EDE CBC","SHA","Not recommended","Yes","RFC5054"],["0xC01D","TLS_SRP_SHA_WITH_AES_128_CBC_SHA","SRP SHA","AES 128 CBC","SHA","Not recommended","Yes","RFC5054"],["0xC01E","TLS_SRP_SHA_RSA_WITH_AES_128_CBC_SHA","SRP SHA RSA","AES 128 CBC","SHA","Not recommended","Yes","RFC5054"],["0xC01F","TLS_SRP_SHA_DSS_WITH_AES_128_CBC_SHA","SRP SHA DSS","AES 128 CBC","SHA","Not recommended","Yes","RFC5054"],["0xC020","TLS_SRP_SHA_WITH_AES_256_CBC_SHA","SRP SHA","AES 256 CBC","SHA","Not recommended","Yes","RFC5054"],["0xC021","TLS_SRP_SHA_RSA_WITH_AES_256_CBC_SHA","SRP SHA RSA","AES 256 CBC","SHA","Not recommended","Yes","RFC5054"],["0xC022","TLS_SRP_SHA_DSS_WITH_AES_256_CBC_SHA","SRP SHA DSS","AES 256 CBC","SHA","Not recommended","Yes","RFC5054"],["0xC023","TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256","ECDHE ECDSA","AES 128 CBC","SHA256","Not recommended","Yes","RFC5289"],["0xC024","TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA384","ECDHE ECDSA","AES 256 CBC","SHA384","Not recommended","Yes","RFC5289"],["0xC025","TLS_ECDH_ECDSA_WITH_AES_128_CBC_SHA256","ECDH ECDSA","AES 128 CBC","SHA256","Discouraged","Yes","RFC5289, RFC10015"],["0xC026","TLS_ECDH_ECDSA_WITH_AES_256_CBC_SHA384","ECDH ECDSA","AES 256 CBC","SHA384","Discouraged","Yes","RFC5289, RFC10015"],["0xC027","TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256","ECDHE RSA","AES 128 CBC","SHA256","Not recommended","Yes","RFC5289"],["0xC028","TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384","ECDHE RSA","AES 256 CBC","SHA384","Not recommended","Yes","RFC5289"],["0xC029","TLS_ECDH_RSA_WITH_AES_128_CBC_SHA256","ECDH RSA","AES 128 CBC","SHA256","Discouraged","Yes","RFC5289, RFC10015"],["0xC02A","TLS_ECDH_RSA_WITH_AES_256_CBC_SHA384","ECDH RSA","AES 256 CBC","SHA384","Discouraged","Yes","RFC5289, RFC10015"],["0xC02B","TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256","ECDHE ECDSA","AES 128 GCM","SHA256","Recommended","Yes","RFC5289"],["0xC02C","TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384","ECDHE ECDSA","AES 256 GCM","SHA384","Recommended","Yes","RFC5289"],["0xC02D","TLS_ECDH_ECDSA_WITH_AES_128_GCM_SHA256","ECDH ECDSA","AES 128 GCM","SHA256","Discouraged","Yes","RFC5289, RFC10015"],["0xC02E","TLS_ECDH_ECDSA_WITH_AES_256_GCM_SHA384","ECDH ECDSA","AES 256 GCM","SHA384","Discouraged","Yes","RFC5289, RFC10015"],["0xC02F","TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256","ECDHE RSA","AES 128 GCM","SHA256","Recommended","Yes","RFC5289"],["0xC030","TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384","ECDHE RSA","AES 256 GCM","SHA384","Recommended","Yes","RFC5289"],["0xC031","TLS_ECDH_RSA_WITH_AES_128_GCM_SHA256","ECDH RSA","AES 128 GCM","SHA256","Discouraged","Yes","RFC5289, RFC10015"],["0xC032","TLS_ECDH_RSA_WITH_AES_256_GCM_SHA384","ECDH RSA","AES 256 GCM","SHA384","Discouraged","Yes","RFC5289, RFC10015"],["0xC033","TLS_ECDHE_PSK_WITH_RC4_128_SHA","ECDHE PSK","RC4 128","SHA","Discouraged","No","RFC5489, RFC6347, RFC9847"],["0xC034","TLS_ECDHE_PSK_WITH_3DES_EDE_CBC_SHA","ECDHE PSK","3DES EDE CBC","SHA","Not recommended","Yes","RFC5489"],["0xC035","TLS_ECDHE_PSK_WITH_AES_128_CBC_SHA","ECDHE PSK","AES 128 CBC","SHA","Not recommended","Yes","RFC5489"],["0xC036","TLS_ECDHE_PSK_WITH_AES_256_CBC_SHA","ECDHE PSK","AES 256 CBC","SHA","Not recommended","Yes","RFC5489"],["0xC037","TLS_ECDHE_PSK_WITH_AES_128_CBC_SHA256","ECDHE PSK","AES 128 CBC","SHA256","Not recommended","Yes","RFC5489"],["0xC038","TLS_ECDHE_PSK_WITH_AES_256_CBC_SHA384","ECDHE PSK","AES 256 CBC","SHA384","Not recommended","Yes","RFC5489"],["0xC039","TLS_ECDHE_PSK_WITH_NULL_SHA","ECDHE PSK","NULL","SHA","Discouraged","Yes","RFC5489, RFC9847"],["0xC03A","TLS_ECDHE_PSK_WITH_NULL_SHA256","ECDHE PSK","NULL","SHA256","Discouraged","Yes","RFC5489, RFC9847"],["0xC03B","TLS_ECDHE_PSK_WITH_NULL_SHA384","ECDHE PSK","NULL","SHA384","Discouraged","Yes","RFC5489, RFC9847"],["0xC03C","TLS_RSA_WITH_ARIA_128_CBC_SHA256","RSA","ARIA 128 CBC","SHA256","Discouraged","Yes","RFC6209, RFC10015"],["0xC03D","TLS_RSA_WITH_ARIA_256_CBC_SHA384","RSA","ARIA 256 CBC","SHA384","Discouraged","Yes","RFC6209, RFC10015"],["0xC03E","TLS_DH_DSS_WITH_ARIA_128_CBC_SHA256","DH DSS","ARIA 128 CBC","SHA256","Discouraged","Yes","RFC6209, RFC10015"],["0xC03F","TLS_DH_DSS_WITH_ARIA_256_CBC_SHA384","DH DSS","ARIA 256 CBC","SHA384","Discouraged","Yes","RFC6209, RFC10015"],["0xC040","TLS_DH_RSA_WITH_ARIA_128_CBC_SHA256","DH RSA","ARIA 128 CBC","SHA256","Discouraged","Yes","RFC6209, RFC10015"],["0xC041","TLS_DH_RSA_WITH_ARIA_256_CBC_SHA384","DH RSA","ARIA 256 CBC","SHA384","Discouraged","Yes","RFC6209, RFC10015"],["0xC042","TLS_DHE_DSS_WITH_ARIA_128_CBC_SHA256","DHE DSS","ARIA 128 CBC","SHA256","Discouraged","Yes","RFC6209, RFC10015"],["0xC043","TLS_DHE_DSS_WITH_ARIA_256_CBC_SHA384","DHE DSS","ARIA 256 CBC","SHA384","Discouraged","Yes","RFC6209, RFC10015"],["0xC044","TLS_DHE_RSA_WITH_ARIA_128_CBC_SHA256","DHE RSA","ARIA 128 CBC","SHA256","Discouraged","Yes","RFC6209, RFC10015"],["0xC045","TLS_DHE_RSA_WITH_ARIA_256_CBC_SHA384","DHE RSA","ARIA 256 CBC","SHA384","Discouraged","Yes","RFC6209, RFC10015"],["0xC046","TLS_DH_anon_WITH_ARIA_128_CBC_SHA256","DH anon","ARIA 128 CBC","SHA256","Discouraged","Yes","RFC6209, RFC10015"],["0xC047","TLS_DH_anon_WITH_ARIA_256_CBC_SHA384","DH anon","ARIA 256 CBC","SHA384","Discouraged","Yes","RFC6209, RFC10015"],["0xC048","TLS_ECDHE_ECDSA_WITH_ARIA_128_CBC_SHA256","ECDHE ECDSA","ARIA 128 CBC","SHA256","Not recommended","Yes","RFC6209"],["0xC049","TLS_ECDHE_ECDSA_WITH_ARIA_256_CBC_SHA384","ECDHE ECDSA","ARIA 256 CBC","SHA384","Not recommended","Yes","RFC6209"],["0xC04A","TLS_ECDH_ECDSA_WITH_ARIA_128_CBC_SHA256","ECDH ECDSA","ARIA 128 CBC","SHA256","Discouraged","Yes","RFC6209, RFC10015"],["0xC04B","TLS_ECDH_ECDSA_WITH_ARIA_256_CBC_SHA384","ECDH ECDSA","ARIA 256 CBC","SHA384","Discouraged","Yes","RFC6209, RFC10015"],["0xC04C","TLS_ECDHE_RSA_WITH_ARIA_128_CBC_SHA256","ECDHE RSA","ARIA 128 CBC","SHA256","Not recommended","Yes","RFC6209"],["0xC04D","TLS_ECDHE_RSA_WITH_ARIA_256_CBC_SHA384","ECDHE RSA","ARIA 256 CBC","SHA384","Not recommended","Yes","RFC6209"],["0xC04E","TLS_ECDH_RSA_WITH_ARIA_128_CBC_SHA256","ECDH RSA","ARIA 128 CBC","SHA256","Discouraged","Yes","RFC6209, RFC10015"],["0xC04F","TLS_ECDH_RSA_WITH_ARIA_256_CBC_SHA384","ECDH RSA","ARIA 256 CBC","SHA384","Discouraged","Yes","RFC6209, RFC10015"],["0xC050","TLS_RSA_WITH_ARIA_128_GCM_SHA256","RSA","ARIA 128 GCM","SHA256","Discouraged","Yes","RFC6209, RFC10015"],["0xC051","TLS_RSA_WITH_ARIA_256_GCM_SHA384","RSA","ARIA 256 GCM","SHA384","Discouraged","Yes","RFC6209, RFC10015"],["0xC052","TLS_DHE_RSA_WITH_ARIA_128_GCM_SHA256","DHE RSA","ARIA 128 GCM","SHA256","Discouraged","Yes","RFC6209, RFC10015"],["0xC053","TLS_DHE_RSA_WITH_ARIA_256_GCM_SHA384","DHE RSA","ARIA 256 GCM","SHA384","Discouraged","Yes","RFC6209, RFC10015"],["0xC054","TLS_DH_RSA_WITH_ARIA_128_GCM_SHA256","DH RSA","ARIA 128 GCM","SHA256","Discouraged","Yes","RFC6209, RFC10015"],["0xC055","TLS_DH_RSA_WITH_ARIA_256_GCM_SHA384","DH RSA","ARIA 256 GCM","SHA384","Discouraged","Yes","RFC6209, RFC10015"],["0xC056","TLS_DHE_DSS_WITH_ARIA_128_GCM_SHA256","DHE DSS","ARIA 128 GCM","SHA256","Discouraged","Yes","RFC6209, RFC10015"],["0xC057","TLS_DHE_DSS_WITH_ARIA_256_GCM_SHA384","DHE DSS","ARIA 256 GCM","SHA384","Discouraged","Yes","RFC6209, RFC10015"],["0xC058","TLS_DH_DSS_WITH_ARIA_128_GCM_SHA256","DH DSS","ARIA 128 GCM","SHA256","Discouraged","Yes","RFC6209, RFC10015"],["0xC059","TLS_DH_DSS_WITH_ARIA_256_GCM_SHA384","DH DSS","ARIA 256 GCM","SHA384","Discouraged","Yes","RFC6209, RFC10015"],["0xC05A","TLS_DH_anon_WITH_ARIA_128_GCM_SHA256","DH anon","ARIA 128 GCM","SHA256","Discouraged","Yes","RFC6209, RFC10015"],["0xC05B","TLS_DH_anon_WITH_ARIA_256_GCM_SHA384","DH anon","ARIA 256 GCM","SHA384","Discouraged","Yes","RFC6209, RFC10015"],["0xC05C","TLS_ECDHE_ECDSA_WITH_ARIA_128_GCM_SHA256","ECDHE ECDSA","ARIA 128 GCM","SHA256","Not recommended","Yes","RFC6209"],["0xC05D","TLS_ECDHE_ECDSA_WITH_ARIA_256_GCM_SHA384","ECDHE ECDSA","ARIA 256 GCM","SHA384","Not recommended","Yes","RFC6209"],["0xC05E","TLS_ECDH_ECDSA_WITH_ARIA_128_GCM_SHA256","ECDH ECDSA","ARIA 128 GCM","SHA256","Discouraged","Yes","RFC6209, RFC10015"],["0xC05F","TLS_ECDH_ECDSA_WITH_ARIA_256_GCM_SHA384","ECDH ECDSA","ARIA 256 GCM","SHA384","Discouraged","Yes","RFC6209, RFC10015"],["0xC060","TLS_ECDHE_RSA_WITH_ARIA_128_GCM_SHA256","ECDHE RSA","ARIA 128 GCM","SHA256","Not recommended","Yes","RFC6209"],["0xC061","TLS_ECDHE_RSA_WITH_ARIA_256_GCM_SHA384","ECDHE RSA","ARIA 256 GCM","SHA384","Not recommended","Yes","RFC6209"],["0xC062","TLS_ECDH_RSA_WITH_ARIA_128_GCM_SHA256","ECDH RSA","ARIA 128 GCM","SHA256","Discouraged","Yes","RFC6209, RFC10015"],["0xC063","TLS_ECDH_RSA_WITH_ARIA_256_GCM_SHA384","ECDH RSA","ARIA 256 GCM","SHA384","Discouraged","Yes","RFC6209, RFC10015"],["0xC064","TLS_PSK_WITH_ARIA_128_CBC_SHA256","PSK","ARIA 128 CBC","SHA256","Not recommended","Yes","RFC6209"],["0xC065","TLS_PSK_WITH_ARIA_256_CBC_SHA384","PSK","ARIA 256 CBC","SHA384","Not recommended","Yes","RFC6209"],["0xC066","TLS_DHE_PSK_WITH_ARIA_128_CBC_SHA256","DHE PSK","ARIA 128 CBC","SHA256","Discouraged","Yes","RFC6209, RFC10015"],["0xC067","TLS_DHE_PSK_WITH_ARIA_256_CBC_SHA384","DHE PSK","ARIA 256 CBC","SHA384","Discouraged","Yes","RFC6209, RFC10015"],["0xC068","TLS_RSA_PSK_WITH_ARIA_128_CBC_SHA256","RSA PSK","ARIA 128 CBC","SHA256","Discouraged","Yes","RFC6209, RFC10015"],["0xC069","TLS_RSA_PSK_WITH_ARIA_256_CBC_SHA384","RSA PSK","ARIA 256 CBC","SHA384","Discouraged","Yes","RFC6209, RFC10015"],["0xC06A","TLS_PSK_WITH_ARIA_128_GCM_SHA256","PSK","ARIA 128 GCM","SHA256","Not recommended","Yes","RFC6209"],["0xC06B","TLS_PSK_WITH_ARIA_256_GCM_SHA384","PSK","ARIA 256 GCM","SHA384","Not recommended","Yes","RFC6209"],["0xC06C","TLS_DHE_PSK_WITH_ARIA_128_GCM_SHA256","DHE PSK","ARIA 128 GCM","SHA256","Discouraged","Yes","RFC6209, RFC10015"],["0xC06D","TLS_DHE_PSK_WITH_ARIA_256_GCM_SHA384","DHE PSK","ARIA 256 GCM","SHA384","Discouraged","Yes","RFC6209, RFC10015"],["0xC06E","TLS_RSA_PSK_WITH_ARIA_128_GCM_SHA256","RSA PSK","ARIA 128 GCM","SHA256","Discouraged","Yes","RFC6209, RFC10015"],["0xC06F","TLS_RSA_PSK_WITH_ARIA_256_GCM_SHA384","RSA PSK","ARIA 256 GCM","SHA384","Discouraged","Yes","RFC6209, RFC10015"],["0xC070","TLS_ECDHE_PSK_WITH_ARIA_128_CBC_SHA256","ECDHE PSK","ARIA 128 CBC","SHA256","Not recommended","Yes","RFC6209"],["0xC071","TLS_ECDHE_PSK_WITH_ARIA_256_CBC_SHA384","ECDHE PSK","ARIA 256 CBC","SHA384","Not recommended","Yes","RFC6209"],["0xC072","TLS_ECDHE_ECDSA_WITH_CAMELLIA_128_CBC_SHA256","ECDHE ECDSA","CAMELLIA 128 CBC","SHA256","Not recommended","Yes","RFC6367"],["0xC073","TLS_ECDHE_ECDSA_WITH_CAMELLIA_256_CBC_SHA384","ECDHE ECDSA","CAMELLIA 256 CBC","SHA384","Not recommended","Yes","RFC6367"],["0xC074","TLS_ECDH_ECDSA_WITH_CAMELLIA_128_CBC_SHA256","ECDH ECDSA","CAMELLIA 128 CBC","SHA256","Discouraged","Yes","RFC6367, RFC10015"],["0xC075","TLS_ECDH_ECDSA_WITH_CAMELLIA_256_CBC_SHA384","ECDH ECDSA","CAMELLIA 256 CBC","SHA384","Discouraged","Yes","RFC6367, RFC10015"],["0xC076","TLS_ECDHE_RSA_WITH_CAMELLIA_128_CBC_SHA256","ECDHE RSA","CAMELLIA 128 CBC","SHA256","Not recommended","Yes","RFC6367"],["0xC077","TLS_ECDHE_RSA_WITH_CAMELLIA_256_CBC_SHA384","ECDHE RSA","CAMELLIA 256 CBC","SHA384","Not recommended","Yes","RFC6367"],["0xC078","TLS_ECDH_RSA_WITH_CAMELLIA_128_CBC_SHA256","ECDH RSA","CAMELLIA 128 CBC","SHA256","Discouraged","Yes","RFC6367, RFC10015"],["0xC079","TLS_ECDH_RSA_WITH_CAMELLIA_256_CBC_SHA384","ECDH RSA","CAMELLIA 256 CBC","SHA384","Discouraged","Yes","RFC6367, RFC10015"],["0xC07A","TLS_RSA_WITH_CAMELLIA_128_GCM_SHA256","RSA","CAMELLIA 128 GCM","SHA256","Discouraged","Yes","RFC6367, RFC10015"],["0xC07B","TLS_RSA_WITH_CAMELLIA_256_GCM_SHA384","RSA","CAMELLIA 256 GCM","SHA384","Discouraged","Yes","RFC6367, RFC10015"],["0xC07C","TLS_DHE_RSA_WITH_CAMELLIA_128_GCM_SHA256","DHE RSA","CAMELLIA 128 GCM","SHA256","Discouraged","Yes","RFC6367, RFC10015"],["0xC07D","TLS_DHE_RSA_WITH_CAMELLIA_256_GCM_SHA384","DHE RSA","CAMELLIA 256 GCM","SHA384","Discouraged","Yes","RFC6367, RFC10015"],["0xC07E","TLS_DH_RSA_WITH_CAMELLIA_128_GCM_SHA256","DH RSA","CAMELLIA 128 GCM","SHA256","Discouraged","Yes","RFC6367, RFC10015"],["0xC07F","TLS_DH_RSA_WITH_CAMELLIA_256_GCM_SHA384","DH RSA","CAMELLIA 256 GCM","SHA384","Discouraged","Yes","RFC6367, RFC10015"],["0xC080","TLS_DHE_DSS_WITH_CAMELLIA_128_GCM_SHA256","DHE DSS","CAMELLIA 128 GCM","SHA256","Discouraged","Yes","RFC6367, RFC10015"],["0xC081","TLS_DHE_DSS_WITH_CAMELLIA_256_GCM_SHA384","DHE DSS","CAMELLIA 256 GCM","SHA384","Discouraged","Yes","RFC6367, RFC10015"],["0xC082","TLS_DH_DSS_WITH_CAMELLIA_128_GCM_SHA256","DH DSS","CAMELLIA 128 GCM","SHA256","Discouraged","Yes","RFC6367, RFC10015"],["0xC083","TLS_DH_DSS_WITH_CAMELLIA_256_GCM_SHA384","DH DSS","CAMELLIA 256 GCM","SHA384","Discouraged","Yes","RFC6367, RFC10015"],["0xC084","TLS_DH_anon_WITH_CAMELLIA_128_GCM_SHA256","DH anon","CAMELLIA 128 GCM","SHA256","Discouraged","Yes","RFC6367, RFC10015"],["0xC085","TLS_DH_anon_WITH_CAMELLIA_256_GCM_SHA384","DH anon","CAMELLIA 256 GCM","SHA384","Discouraged","Yes","RFC6367, RFC10015"],["0xC086","TLS_ECDHE_ECDSA_WITH_CAMELLIA_128_GCM_SHA256","ECDHE ECDSA","CAMELLIA 128 GCM","SHA256","Not recommended","Yes","RFC6367"],["0xC087","TLS_ECDHE_ECDSA_WITH_CAMELLIA_256_GCM_SHA384","ECDHE ECDSA","CAMELLIA 256 GCM","SHA384","Not recommended","Yes","RFC6367"],["0xC088","TLS_ECDH_ECDSA_WITH_CAMELLIA_128_GCM_SHA256","ECDH ECDSA","CAMELLIA 128 GCM","SHA256","Discouraged","Yes","RFC6367, RFC10015"],["0xC089","TLS_ECDH_ECDSA_WITH_CAMELLIA_256_GCM_SHA384","ECDH ECDSA","CAMELLIA 256 GCM","SHA384","Discouraged","Yes","RFC6367, RFC10015"],["0xC08A","TLS_ECDHE_RSA_WITH_CAMELLIA_128_GCM_SHA256","ECDHE RSA","CAMELLIA 128 GCM","SHA256","Not recommended","Yes","RFC6367"],["0xC08B","TLS_ECDHE_RSA_WITH_CAMELLIA_256_GCM_SHA384","ECDHE RSA","CAMELLIA 256 GCM","SHA384","Not recommended","Yes","RFC6367"],["0xC08C","TLS_ECDH_RSA_WITH_CAMELLIA_128_GCM_SHA256","ECDH RSA","CAMELLIA 128 GCM","SHA256","Discouraged","Yes","RFC6367, RFC10015"],["0xC08D","TLS_ECDH_RSA_WITH_CAMELLIA_256_GCM_SHA384","ECDH RSA","CAMELLIA 256 GCM","SHA384","Discouraged","Yes","RFC6367, RFC10015"],["0xC08E","TLS_PSK_WITH_CAMELLIA_128_GCM_SHA256","PSK","CAMELLIA 128 GCM","SHA256","Not recommended","Yes","RFC6367"],["0xC08F","TLS_PSK_WITH_CAMELLIA_256_GCM_SHA384","PSK","CAMELLIA 256 GCM","SHA384","Not recommended","Yes","RFC6367"],["0xC090","TLS_DHE_PSK_WITH_CAMELLIA_128_GCM_SHA256","DHE PSK","CAMELLIA 128 GCM","SHA256","Discouraged","Yes","RFC6367, RFC10015"],["0xC091","TLS_DHE_PSK_WITH_CAMELLIA_256_GCM_SHA384","DHE PSK","CAMELLIA 256 GCM","SHA384","Discouraged","Yes","RFC6367, RFC10015"],["0xC092","TLS_RSA_PSK_WITH_CAMELLIA_128_GCM_SHA256","RSA PSK","CAMELLIA 128 GCM","SHA256","Discouraged","Yes","RFC6367, RFC10015"],["0xC093","TLS_RSA_PSK_WITH_CAMELLIA_256_GCM_SHA384","RSA PSK","CAMELLIA 256 GCM","SHA384","Discouraged","Yes","RFC6367, RFC10015"],["0xC094","TLS_PSK_WITH_CAMELLIA_128_CBC_SHA256","PSK","CAMELLIA 128 CBC","SHA256","Not recommended","Yes","RFC6367"],["0xC095","TLS_PSK_WITH_CAMELLIA_256_CBC_SHA384","PSK","CAMELLIA 256 CBC","SHA384","Not recommended","Yes","RFC6367"],["0xC096","TLS_DHE_PSK_WITH_CAMELLIA_128_CBC_SHA256","DHE PSK","CAMELLIA 128 CBC","SHA256","Discouraged","Yes","RFC6367, RFC10015"],["0xC097","TLS_DHE_PSK_WITH_CAMELLIA_256_CBC_SHA384","DHE PSK","CAMELLIA 256 CBC","SHA384","Discouraged","Yes","RFC6367, RFC10015"],["0xC098","TLS_RSA_PSK_WITH_CAMELLIA_128_CBC_SHA256","RSA PSK","CAMELLIA 128 CBC","SHA256","Discouraged","Yes","RFC6367, RFC10015"],["0xC099","TLS_RSA_PSK_WITH_CAMELLIA_256_CBC_SHA384","RSA PSK","CAMELLIA 256 CBC","SHA384","Discouraged","Yes","RFC6367, RFC10015"],["0xC09A","TLS_ECDHE_PSK_WITH_CAMELLIA_128_CBC_SHA256","ECDHE PSK","CAMELLIA 128 CBC","SHA256","Not recommended","Yes","RFC6367"],["0xC09B","TLS_ECDHE_PSK_WITH_CAMELLIA_256_CBC_SHA384","ECDHE PSK","CAMELLIA 256 CBC","SHA384","Not recommended","Yes","RFC6367"],["0xC09C","TLS_RSA_WITH_AES_128_CCM","RSA","AES 128 CCM","","Discouraged","Yes","RFC6655, RFC10015"],["0xC09D","TLS_RSA_WITH_AES_256_CCM","RSA","AES 256 CCM","","Discouraged","Yes","RFC6655, RFC10015"],["0xC09E","TLS_DHE_RSA_WITH_AES_128_CCM","DHE RSA","AES 128 CCM","","Discouraged","Yes","RFC6655, RFC10015"],["0xC09F","TLS_DHE_RSA_WITH_AES_256_CCM","DHE RSA","AES 256 CCM","","Discouraged","Yes","RFC6655, RFC10015"],["0xC0A0","TLS_RSA_WITH_AES_128_CCM_8","RSA","AES 128 CCM 8","","Discouraged","Yes","RFC6655, RFC10015"],["0xC0A1","TLS_RSA_WITH_AES_256_CCM_8","RSA","AES 256 CCM 8","","Discouraged","Yes","RFC6655, RFC10015"],["0xC0A2","TLS_DHE_RSA_WITH_AES_128_CCM_8","DHE RSA","AES 128 CCM 8","","Discouraged","Yes","RFC6655, RFC10015"],["0xC0A3","TLS_DHE_RSA_WITH_AES_256_CCM_8","DHE RSA","AES 256 CCM 8","","Discouraged","No","RFC6655, RFC10015"],["0xC0A4","TLS_PSK_WITH_AES_128_CCM","PSK","AES 128 CCM","","Not recommended","Yes","RFC6655"],["0xC0A5","TLS_PSK_WITH_AES_256_CCM","PSK","AES 256 CCM","","Not recommended","Yes","RFC6655"],["0xC0A6","TLS_DHE_PSK_WITH_AES_128_CCM","DHE PSK","AES 128 CCM","","Discouraged","Yes","RFC6655, RFC10015"],["0xC0A7","TLS_DHE_PSK_WITH_AES_256_CCM","DHE PSK","AES 256 CCM","","Discouraged","Yes","RFC6655, RFC10015"],["0xC0A8","TLS_PSK_WITH_AES_128_CCM_8","PSK","AES 128 CCM 8","","Not recommended","Yes","RFC6655"],["0xC0A9","TLS_PSK_WITH_AES_256_CCM_8","PSK","AES 256 CCM 8","","Not recommended","Yes","RFC6655"],["0xC0AA","TLS_PSK_DHE_WITH_AES_128_CCM_8","PSK DHE","AES 128 CCM 8","","Discouraged","Yes","RFC6655, RFC10015"],["0xC0AB","TLS_PSK_DHE_WITH_AES_256_CCM_8","PSK DHE","AES 256 CCM 8","","Discouraged","Yes","RFC6655, RFC10015"],["0xC0AC","TLS_ECDHE_ECDSA_WITH_AES_128_CCM","ECDHE ECDSA","AES 128 CCM","","Not recommended","Yes","RFC7251"],["0xC0AD","TLS_ECDHE_ECDSA_WITH_AES_256_CCM","ECDHE ECDSA","AES 256 CCM","","Not recommended","Yes","RFC7251"],["0xC0AE","TLS_ECDHE_ECDSA_WITH_AES_128_CCM_8","ECDHE ECDSA","AES 128 CCM 8","","Not recommended","Yes","RFC7251"],["0xC0AF","TLS_ECDHE_ECDSA_WITH_AES_256_CCM_8","ECDHE ECDSA","AES 256 CCM 8","","Not recommended","Yes","RFC7251"],["0xC0B0","TLS_ECCPWD_WITH_AES_128_GCM_SHA256","ECCPWD","AES 128 GCM","SHA256","Not recommended","Yes","RFC8492"],["0xC0B1","TLS_ECCPWD_WITH_AES_256_GCM_SHA384","ECCPWD","AES 256 GCM","SHA384","Not recommended","Yes","RFC8492"],["0xC0B2","TLS_ECCPWD_WITH_AES_128_CCM_SHA256","ECCPWD","AES 128 CCM","SHA256","Not recommended","Yes","RFC8492"],["0xC0B3","TLS_ECCPWD_WITH_AES_256_CCM_SHA384","ECCPWD","AES 256 CCM","SHA384","Not recommended","Yes","RFC8492"],["0xC0B4","TLS_SHA256_SHA256","Any (TLS 1.3)","SHA256","SHA256","Discouraged","Yes","RFC9150, RFC9847"],["0xC0B5","TLS_SHA384_SHA384","Any (TLS 1.3)","SHA384","SHA384","Discouraged","Yes","RFC9150, RFC9847"],["0xC100","TLS_GOSTR341112_256_WITH_KUZNYECHIK_CTR_OMAC","GOSTR341112 256","KUZNYECHIK CTR OMAC","","Not recommended","No","RFC9189"],["0xC101","TLS_GOSTR341112_256_WITH_MAGMA_CTR_OMAC","GOSTR341112 256","MAGMA CTR OMAC","","Not recommended","No","RFC9189"],["0xC102","TLS_GOSTR341112_256_WITH_28147_CNT_IMIT","GOSTR341112 256","28147 CNT IMIT","","Not recommended","No","RFC9189"],["0xC103","TLS_GOSTR341112_256_WITH_KUZNYECHIK_MGM_L","GOSTR341112 256","KUZNYECHIK MGM L","","Not recommended","No","RFC9367"],["0xC104","TLS_GOSTR341112_256_WITH_MAGMA_MGM_L","GOSTR341112 256","MAGMA MGM L","","Not recommended","No","RFC9367"],["0xC105","TLS_GOSTR341112_256_WITH_KUZNYECHIK_MGM_S","GOSTR341112 256","KUZNYECHIK MGM S","","Not recommended","No","RFC9367"],["0xC106","TLS_GOSTR341112_256_WITH_MAGMA_MGM_S","GOSTR341112 256","MAGMA MGM S","","Not recommended","No","RFC9367"],["0xCCA8","TLS_ECDHE_RSA_WITH_CHACHA20_POLY1305_SHA256","ECDHE RSA","CHACHA20 POLY1305","SHA256","Recommended","Yes","RFC7905"],["0xCCA9","TLS_ECDHE_ECDSA_WITH_CHACHA20_POLY1305_SHA256","ECDHE ECDSA","CHACHA20 POLY1305","SHA256","Recommended","Yes","RFC7905"],["0xCCAA","TLS_DHE_RSA_WITH_CHACHA20_POLY1305_SHA256","DHE RSA","CHACHA20 POLY1305","SHA256","Discouraged","Yes","RFC7905, RFC10015"],["0xCCAB","TLS_PSK_WITH_CHACHA20_POLY1305_SHA256","PSK","CHACHA20 POLY1305","SHA256","Not recommended","Yes","RFC7905"],["0xCCAC","TLS_ECDHE_PSK_WITH_CHACHA20_POLY1305_SHA256","ECDHE PSK","CHACHA20 POLY1305","SHA256","Recommended","Yes","RFC7905"],["0xCCAD","TLS_DHE_PSK_WITH_CHACHA20_POLY1305_SHA256","DHE PSK","CHACHA20 POLY1305","SHA256","Discouraged","Yes","RFC7905, RFC10015"],["0xCCAE","TLS_RSA_PSK_WITH_CHACHA20_POLY1305_SHA256","RSA PSK","CHACHA20 POLY1305","SHA256","Discouraged","Yes","RFC7905, RFC10015"],["0xD001","TLS_ECDHE_PSK_WITH_AES_128_GCM_SHA256","ECDHE PSK","AES 128 GCM","SHA256","Recommended","Yes","RFC8442"],["0xD002","TLS_ECDHE_PSK_WITH_AES_256_GCM_SHA384","ECDHE PSK","AES 256 GCM","SHA384","Recommended","Yes","RFC8442"],["0xD003","TLS_ECDHE_PSK_WITH_AES_128_CCM_8_SHA256","ECDHE PSK","AES 128 CCM 8","SHA256","Not recommended","Yes","RFC8442"],["0xD005","TLS_ECDHE_PSK_WITH_AES_128_CCM_SHA256","ECDHE PSK","AES 128 CCM","SHA256","Recommended","Yes","RFC8442"]]}